A Mind Lost

Anything and everything.

Tag Archives: Hard drive clicking

Linux Mint 13

Haven’t really had much to say lately.  Windows 7 has been surprisingly obedient, and without any issues I haven’t had much to complain about.  I even finally managed to get Service Pack 1 to behave, after every previous attempt ended in inexplicable bluescreens!

As for Windows 8, I’ll be giving that a pass.  The new UI doesn’t appeal to me at all, and with a smooth-sailing 7 x64 installation I see no reason to upgrade.

What this post is really about, as the title indicates, is Linux Mint.  I tried Mint 12 way back in January, and was not particularly impressed.  Well, a few weeks back I decided to scrap the Slackware install on my notebook, an aging ASUS F8Sn-B1.  Within is an Intel Core 2 Duo T8100 clocked at 2.1GHz, 3GB of memory, an Nvidia Geforce 9500M GS with 512MB of dedicated memory, and the only upgrade I’ve made to it, a 640GB Western Digital Scorpio Blue drive.  Originally I had upgraded to a 500GB Scorpio Black from the stock 250GB Toshiba drive, but after just a few hours of power-on the BIOS started reporting S.M.A.R.T. errors.  RMA’ing the drive required jumping through a few hoops as the drive’s serial number didn’t match where I had purchased the drive from (I’m in Canada).  Western Digital eventually sorted it out with no problems, and I did get an RMA, but in the meantime I had picked up the 640GB drive.

As with my previous try with Mint, the installer went smooth as butter, this time without stalls.  I selected the Xfce version of Mint as I wanted something light yet functional.  After a month of use, I really had no complaints whatsoever, and while I missed Slackware due to my familiarity with it, the ease of software installation and dependency resolution assuaged both my yearning and my guilt.

Unfortunately, I am ever the tinkerer.  The replacement Scorpio Black drive, which had seen infrequent use as an external drive, was taunting me to swap it into the notebook for its better performance.  Don’t get me wrong, the Blue drive has worked great (I also put a desktop Scorpio Blue in the desktop I gave my Dad), but I just couldn’t resist.

This time I decided to give a different flavour of Mint a try.  I started with the KDE version, which is my preference over Gnome and its relatives.  After installing and updating, I set about to tweaking.  One of the features I love about KDE is its customizability.  One of the things I don’t like, however, is its apparent performance.  KDE 4 has always felt “laggy” to me.  Opening windows, moving them, closing them, the interface just feels sluggish.  I don’t remember KDE 3, which I loved, suffering from this.  While it’s not a deal breaker, it is an annoyance.

Then I came across a problem with fonts.  No matter how hard I tried, I couldn’t get the fonts in KDE’s application launcher to look right.  Everything else was fine, desktop, taskbar, tray, and application fonts all looked ok.  Even GTK applications looked great!  Being near-sighted, I find I am sensitive to fonts that don’t look right (and bits of dust and hair on the screen, my laptop’s screen is like a magnet to such), and blurry/fuzzy fonts are just unacceptable.

So with the fonts driving me nuts, something inside me broke for a minute and I decided that since the GTK app fonts looked great, I’d give the Cinnamon version of Mint a try.  Download, wipe, install and update again.

Yes, I realize I could have just grabbed everything via Synaptic and done an in-place change to Cinnamon, but I reasoned that if I was switching to Cinnamon I wouldn’t need the bulk of the KDE stuff, and that it was just easier to grab a different .ISO, rather than tediously going through all the installed packages and removing the unneeded ones.

So, Cinnamon.  The Mint guys have done a great job making Gnome 3 usable, so much “props” to them for that, but it’s still Gnome and I really just don’t like it.  I haven’t used Unity, and probably never will as I don’t like the direction they’ve taken with it as a user interface (much the same as I don’t like Windows 8’s Metro).  But no matter the work they put in to Cinnamon, it’s still Gnome, and I find there’s just not enough options to make me feel comfortable with it.  And the application launcher is horrible!

There were other little things that bothered me, such as the Alt+F2 launcher not offering suggestions, but the final straw came when X crashed in the midst of opening a window and dumped me back to the login manager, a problem I did not experience in either Xfce or KDE.

I didn’t try the Debian edition of Linux Mint, because after KDE, then Cinnamon, I was frustrated and had had enough.  So, I’ve come full circle and reinstall Linux Mint Xfce.  My notebook feels snappy and the interface offers enough customization to make me happy (though to be honest I like Xfce’s out-of-box experience).

The TL;DR is Linux Mint 13 Xfce gets a definite two thumbs up from me.

Something else I want to mention here regarding the Western Digital Scorpio Black drive.  As with many drives from WD, it seemed particularly aggressive about parking the head.  Every 8 seconds without activity the drive would emit a loud clunk as it moved the head into the landing zone.

I also experienced this with the Scorpio Blue, and worked around the issue by adding a call to hdparm within the local rc startup script (/etc/rc.d/rc.local in Slackware, and /etc/rc.local in Mint):

hdparm -B 255 /dev/sda

This completely shuts off power-management for the drive.  I did the same with the Black drive, but this had no apparent effect!  After Googling, I came across the WDIDLE3 utility on Western Digital’s website.  This software cannot be run under anything but DOS; fortunately, I happen to have a bootable USB drive with a copy of FreeDOS on it.  Keeping a bootable FreeDOS USB stick has been incredibly useful, as I also used it to flash the firmware for my motherboard’s Asmedia USB 3 hardware.  Also, I nostalgia’d hard upon seeing a fullscreen bare C:\ prompt.  Oh the memories.

However, even after using the software to completely disable the idle timer, the drive was still merrily clicking away as it parked the head.  After another reboot in to FreeDOS, I decided to set the timer to its maximim value of 300 (that’s 5 minutes).  Since the drive is touched in some way in much smaller intervals than 5 minutes, this has effectively worked to eliminate the head parking.

Note that the head parking is, in general, a good thing.  However, for my usage scenario it’s not necessary.  I don’t carry the notebook around while it’s running, or often move or jostle it.  I’m fairly delicate with my computers.

Also note that although the drive (I don’t have the exact model available atm) wasn’t listed on the WDIDLE3 page, the program did work just fine.  YMMV, just be aware that messing with low-level stuff like this can render your hardware useless.

Advertisements